assistant-4.8.7.ebuild 1.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils qt4-build-multilib
  5. DESCRIPTION="Tool for viewing on-line documentation in Qt help file format"
  6. if [[ ${QT4_BUILD_TYPE} == release ]]; then
  7. KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
  8. fi
  9. IUSE="webkit"
  10. DEPEND="
  11. ~dev-qt/qtcore-${PV}[aqua=,debug=,${MULTILIB_USEDEP}]
  12. ~dev-qt/qtgui-${PV}[aqua=,debug=,${MULTILIB_USEDEP}]
  13. ~dev-qt/qthelp-${PV}[aqua=,debug=,${MULTILIB_USEDEP}]
  14. ~dev-qt/qtsql-${PV}[aqua=,debug=,sqlite,${MULTILIB_USEDEP}]
  15. webkit? ( ~dev-qt/qtwebkit-${PV}[aqua=,debug=,${MULTILIB_USEDEP}] )
  16. "
  17. RDEPEND="${DEPEND}"
  18. PATCHES=(
  19. "${FILESDIR}/${PN}-4.8.2+gcc-4.7.patch"
  20. )
  21. QT4_TARGET_DIRECTORIES="tools/assistant/tools/assistant"
  22. src_prepare() {
  23. # bug 401173
  24. use webkit || PATCHES+=("${FILESDIR}/disable-webkit.patch")
  25. qt4-build-multilib_src_prepare
  26. }
  27. multilib_src_configure() {
  28. local myconf=(
  29. -system-libpng -system-libjpeg -system-zlib
  30. -no-sql-mysql -no-sql-psql -no-sql-ibase -no-sql-sqlite2 -no-sql-odbc
  31. -sm -xshape -xsync -xcursor -xfixes -xrandr -xrender -mitshm -xinput -xkb
  32. -fontconfig -no-multimedia -no-opengl -no-phonon -no-svg -no-xmlpatterns
  33. $(qt_use webkit)
  34. )
  35. qt4_multilib_src_configure
  36. }
  37. multilib_src_install_all() {
  38. qt4_multilib_src_install_all
  39. doicon tools/assistant/tools/assistant/images/assistant.png
  40. make_desktop_entry assistant Assistant assistant 'Qt;Development;Documentation'
  41. }