qtconcurrent-5.6.2.ebuild 433 B

123456789101112131415161718192021222324
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. QT5_MODULE="qtbase"
  5. inherit qt5-build
  6. DESCRIPTION="Multi-threading concurrence support library for the Qt5 framework"
  7. if [[ ${QT5_BUILD_TYPE} == release ]]; then
  8. KEYWORDS="amd64 arm ~arm64 hppa ppc ppc64 x86"
  9. fi
  10. IUSE=""
  11. DEPEND="
  12. ~dev-qt/qtcore-${PV}
  13. "
  14. RDEPEND="${DEPEND}"
  15. QT5_TARGET_SUBDIRS=(
  16. src/concurrent
  17. )