bless-0.6.0-r2.ebuild 1.2 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit autotools gnome2 mono-env
  5. DESCRIPTION="GTK# Hex Editor"
  6. HOMEPAGE="http://home.gna.org/bless/"
  7. SRC_URI="http://download.gna.org/bless/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE="debug"
  12. RDEPEND="
  13. >=dev-lang/mono-1.1.14
  14. >=dev-dotnet/gtk-sharp-2.12
  15. || ( >=dev-dotnet/gtk-sharp-2.12.21
  16. >=dev-dotnet/glade-sharp-2.12 )
  17. "
  18. DEPEND="${RDEPEND}
  19. app-text/rarian
  20. >=sys-devel/gettext-0.15
  21. virtual/pkgconfig
  22. "
  23. # See bug 278162
  24. # Waiting on nunit ebuild entering the tree
  25. RESTRICT="test"
  26. pkg_setup() {
  27. # Stolen from enlightenment.eclass
  28. cp $(type -p gettextize) "${T}/" || die "Could not copy gettextize"
  29. sed -i -e 's:read dummy < /dev/tty::' "${T}/gettextize"
  30. }
  31. src_prepare() {
  32. einfo "Running gettextize -f --no-changelog..."
  33. ( "${T}/gettextize" -f --no-changelog > /dev/null ) || die "gettexize failed"
  34. eapply "${FILESDIR}/${P}-pixmap.patch"
  35. eapply "${FILESDIR}/${P}-docpath.patch"
  36. eapply "${FILESDIR}/${P}-mono-4.patch"
  37. eautoreconf
  38. gnome2_src_prepare
  39. }
  40. src_configure() {
  41. gnome2_src_configure \
  42. --enable-unix-specific \
  43. $(use_enable debug)
  44. }