buildbot-www-0.9.1.ebuild 1.0 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. PYTHON_REQ_USE="sqlite"
  5. PYTHON_COMPAT=( python2_7 )
  6. EGIT_REPO_URI="git://github.com/buildbot/buildbot.git"
  7. [[ ${PV} == *9999 ]] && inherit git-r3
  8. inherit distutils-r1
  9. DESCRIPTION="BuildBot base web interface, use with buildbot-{console-view,waterfall-view}..."
  10. HOMEPAGE="http://buildbot.net/ https://github.com/buildbot/buildbot https://pypi.python.org/pypi/buildbot-www"
  11. MY_V="0.9.1"
  12. MY_P="${PN}-${MY_V}"
  13. [[ ${PV} == *9999 ]] || SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
  14. LICENSE="GPL-2"
  15. SLOT="0"
  16. if [[ ${PV} == *9999 ]]; then
  17. KEYWORDS=""
  18. else
  19. KEYWORDS="~amd64"
  20. fi
  21. RDEPEND=""
  22. DEPEND="${RDEPEND}
  23. >=dev-python/setuptools-21.2.1[${PYTHON_USEDEP}]
  24. ~dev-util/buildbot-${PV}[${PYTHON_USEDEP}]
  25. ~dev-util/buildbot-pkg-${PV}[${PYTHON_USEDEP}]
  26. dev-python/mock[${PYTHON_USEDEP}]
  27. "
  28. S="${WORKDIR}/${MY_P}"
  29. #[[ ${PV} == *9999 ]] && S=${S}/www/base
  30. python_install_all() {
  31. distutils-r1_python_install_all
  32. }