d-feet-0.3.11.ebuild 1.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit gnome2 python-single-r1 virtualx
  6. DESCRIPTION="D-Feet is a powerful D-Bus debugger"
  7. HOMEPAGE="https://wiki.gnome.org/Apps/DFeet"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86"
  11. IUSE="test"
  12. REQUIRED_USE="${PYTHON_REQUIRED_USE}"
  13. RDEPEND="
  14. >=dev-libs/glib-2.34:2
  15. >=dev-libs/gobject-introspection-0.9.6:=
  16. >=dev-python/pygobject-3.3.91:3[${PYTHON_USEDEP}]
  17. >=sys-apps/dbus-1
  18. >=x11-libs/gtk+-3.9.4:3[introspection]
  19. x11-libs/libwnck:3[introspection]
  20. "
  21. DEPEND="${PYTHON_DEPS}
  22. app-text/yelp-tools
  23. >=dev-util/intltool-0.40.0
  24. "
  25. src_prepare() {
  26. python_fix_shebang .
  27. # Do not run update-desktop-database (sandbox violation)
  28. sed -e '/^UPDATE_DESKTOP/s:=.*:=true:' \
  29. -i data/Makefile.am data/Makefile.in || die
  30. # disable pep8 - checking python whitespace style is not useful for us
  31. sed -e 's/pep8 /# pep8 /' \
  32. -i src/tests/Makefile.am src/tests/Makefile.in || die
  33. gnome2_src_prepare
  34. }
  35. src_configure() {
  36. # disable pep8 - checking python code style is not useful downstream
  37. # (especially when that style check fails!)
  38. gnome2_src_configure \
  39. $(use_enable test tests) \
  40. PEP8=$(type -P true)
  41. }
  42. src_test() {
  43. virtx emake check
  44. }