fatrace-0.12.ebuild 840 B

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python{3_4,3_5} )
  5. inherit linux-info python-r1 toolchain-funcs
  6. DESCRIPTION="report file access events from all running processes"
  7. HOMEPAGE="https://launchpad.net/fatrace"
  8. SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.bz2"
  9. LICENSE="GPL-3"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86"
  12. IUSE="powertop"
  13. RDEPEND="powertop? ( ${PYTHON_DEPS} )"
  14. DEPEND="${RDEPEND}"
  15. REQUIRED_USE="powertop? ( ${PYTHON_REQUIRED_USE} )"
  16. CONFIG_CHECK="~FANOTIFY"
  17. pkg_setup() {
  18. use powertop && python-single-r1_pkg_setup
  19. }
  20. src_prepare() {
  21. epatch "${FILESDIR}"/${PN}-0.11-sysmacros.patch #580082
  22. tc-export CC
  23. }
  24. src_install() {
  25. dosbin fatrace
  26. use powertop && dosbin power-usage-report
  27. doman fatrace.1
  28. dodoc NEWS
  29. }