ltrace-0.7.3.ebuild 887 B

1234567891011121314151617181920212223242526272829303132333435363738
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils autotools
  5. NUM="3947"
  6. DESCRIPTION="trace library calls made at runtime"
  7. HOMEPAGE="http://ltrace.alioth.debian.org/"
  8. SRC_URI="https://alioth.debian.org/frs/download.php/file/${NUM}/${P}.tar.bz2"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="-alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~x86"
  12. IUSE="debug selinux test unwind"
  13. RDEPEND="dev-libs/elfutils
  14. selinux? ( sys-libs/libselinux )
  15. unwind? ( sys-libs/libunwind )"
  16. DEPEND="${RDEPEND}
  17. test? ( dev-util/dejagnu )"
  18. src_prepare() {
  19. sed -i '/^dist_doc_DATA/d' Makefile.am || die
  20. eautoreconf
  21. }
  22. src_configure() {
  23. ac_cv_header_selinux_selinux_h=$(usex selinux) \
  24. ac_cv_lib_selinux_security_get_boolean_active=$(usex selinux) \
  25. econf \
  26. --disable-werror \
  27. $(use_enable debug) \
  28. $(use_with unwind libunwind)
  29. }