meld-3.16.4.ebuild 895 B

12345678910111213141516171819202122232425262728293031323334353637
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="6"
  4. PYTHON_REQ_USE="xml"
  5. PYTHON_COMPAT=( python2_7 )
  6. DISTUTILS_SINGLE_IMPL=1
  7. inherit gnome2 distutils-r1
  8. DESCRIPTION="A graphical diff and merge tool"
  9. HOMEPAGE="http://meldmerge.org/"
  10. LICENSE="GPL-2+"
  11. SLOT="0"
  12. KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
  13. IUSE=""
  14. RDEPEND="${PYTHON_DEPS}
  15. >=dev-libs/glib-2.36:2[dbus]
  16. dev-python/dbus-python[${PYTHON_USEDEP}]
  17. >=dev-python/pygobject-3.8:3[cairo,${PYTHON_USEDEP}]
  18. gnome-base/gsettings-desktop-schemas
  19. >=x11-libs/gtk+-3.14:3[introspection]
  20. >=x11-libs/gtksourceview-3.14:3.0[introspection]
  21. x11-themes/hicolor-icon-theme
  22. "
  23. DEPEND="${RDEPEND}
  24. dev-util/intltool
  25. dev-util/itstool
  26. sys-devel/gettext
  27. "
  28. python_compile_all() {
  29. mydistutilsargs=( --no-update-icon-cache --no-compile-schemas )
  30. }