pkgcheck-9999.ebuild 1.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
  5. DISTUTILS_IN_SOURCE_BUILD=1
  6. inherit distutils-r1
  7. if [[ ${PV} == *9999 ]] ; then
  8. EGIT_REPO_URI="https://github.com/pkgcore/pkgcheck.git"
  9. inherit git-r3
  10. else
  11. KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
  12. SRC_URI="https://github.com/pkgcore/${PN}/releases/download/v${PV}/${P}.tar.gz"
  13. fi
  14. DESCRIPTION="pkgcore-based QA utility"
  15. HOMEPAGE="https://github.com/pkgcore/pkgcheck"
  16. LICENSE="|| ( BSD GPL-2 )"
  17. SLOT="0"
  18. RDEPEND="
  19. =sys-apps/pkgcore-9999[${PYTHON_USEDEP}]
  20. =dev-python/snakeoil-9999[${PYTHON_USEDEP}]
  21. dev-python/lxml[${PYTHON_USEDEP}]
  22. "
  23. DEPEND="${RDEPEND}
  24. dev-python/setuptools[${PYTHON_USEDEP}]"
  25. [[ ${PV} == *9999 ]] && DEPEND+=" dev-python/sphinx[${PYTHON_USEDEP}]"
  26. pkg_setup() {
  27. # disable snakeoil 2to3 caching...
  28. unset PY2TO3_CACHEDIR
  29. }
  30. python_compile_all() {
  31. esetup.py build_man
  32. }
  33. python_test() {
  34. esetup.py test
  35. }
  36. python_install_all() {
  37. local DOCS=( AUTHORS NEWS.rst )
  38. distutils-r1_python_install install_man
  39. distutils-r1_python_install_all
  40. }
  41. pkg_postinst() {
  42. python_foreach_impl pplugincache pkgcheck.plugins
  43. }