qdevicemonitor-1.0.1.ebuild 926 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="6"
  4. inherit eutils qmake-utils
  5. DESCRIPTION="Crossplatform log viewer for Android, iOS and text files"
  6. HOMEPAGE="https://github.com/alopatindev/qdevicemonitor"
  7. if [[ ${PV} == "9999" ]] ; then
  8. inherit git-r3
  9. EGIT_REPO_URI="git://github.com/alopatindev/qdevicemonitor"
  10. else
  11. SRC_URI="https://github.com/alopatindev/qdevicemonitor/archive/${PV}.tar.gz -> ${P}.tar.gz"
  12. KEYWORDS="~amd64 ~x86"
  13. fi
  14. LICENSE="GPL-3"
  15. SLOT="0"
  16. IUSE=""
  17. RDEPEND="
  18. dev-qt/qtcore:5
  19. dev-qt/qtgui:5
  20. dev-util/android-tools
  21. app-pda/usbmuxd"
  22. DEPEND="${RDEPEND}"
  23. src_configure() {
  24. cd "${PN}" || die
  25. export VERSION_WITH_BUILD_NUMBER="${PV}"
  26. eqmake5
  27. }
  28. src_compile() {
  29. cd "${PN}" || die
  30. emake
  31. }
  32. src_install() {
  33. dobin "${PN}/${PN}"
  34. dodoc README.md
  35. newicon -s scalable "icons/app_icon.svg" "${PN}.svg"
  36. domenu "icons/${PN}.desktop"
  37. }