rpmdevtools-8.5.ebuild 695 B

1234567891011121314151617181920212223242526272829303132333435
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. DESCRIPTION="Collection of rpm packaging related utilities"
  5. HOMEPAGE="https://fedorahosted.org/rpmdevtools/"
  6. SRC_URI="https://fedorahosted.org/releases/r/p/${PN}/${P}.tar.xz"
  7. LICENSE="GPL-2"
  8. SLOT="0"
  9. KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
  10. IUSE="emacs"
  11. CDEPEND="
  12. app-arch/rpm[python]
  13. net-misc/curl
  14. emacs? ( app-emacs/rpm-spec-mode )
  15. dev-util/checkbashisms
  16. "
  17. DEPEND="
  18. ${CDEPEND}
  19. dev-lang/perl
  20. =dev-lang/python-2*
  21. sys-apps/help2man
  22. "
  23. RDEPEND="${CDEPEND}"
  24. src_prepare() {
  25. default
  26. sed -i 's:#!/usr/bin/python:#!/usr/bin/python2:' rpmdev-rmdevelrpms.py || die
  27. }