stressapptest-1.0.7_p1.ebuild 692 B

1234567891011121314151617181920212223242526272829
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # This is the 1.0.7 release:
  4. # https://code.google.com/p/stressapptest/source/detail?r=44
  5. # With the one follow up fix applied (hence the p1).
  6. EAPI="4"
  7. inherit flag-o-matic
  8. DESCRIPTION="Stressful Application Test"
  9. HOMEPAGE="https://code.google.com/p/stressapptest/"
  10. SRC_URI="mirror://gentoo/${P}.tar.xz"
  11. LICENSE="Apache-2.0"
  12. SLOT="0"
  13. KEYWORDS="~amd64 ~arm ~mips ~x86"
  14. IUSE="debug"
  15. RDEPEND="dev-libs/libaio"
  16. DEPEND="${RDEPEND}"
  17. src_configure() {
  18. # Matches the configure & sat.cc logic
  19. use debug || append-cppflags -DNDEBUG -DCHECKOPTS
  20. econf --disable-default-optimizations
  21. }