tinlink-1.0.0.ebuild 576 B

12345678910111213141516171819202122232425262728293031
  1. # Copyright 1999-2009 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit toolchain-funcs
  4. DESCRIPTION="a tool to create very small elf binary from pure binary files"
  5. HOMEPAGE="http://sed.free.fr/tinlink/"
  6. SRC_URI="http://sed.free.fr/tinlink/${P}.tar.gz"
  7. LICENSE="public-domain"
  8. SLOT="0"
  9. KEYWORDS="~amd64 ~x86 ~ppc"
  10. IUSE=""
  11. DEPEND=""
  12. RDEPEND=""
  13. src_unpack() {
  14. unpack ${A}
  15. rm -f "${S}"/Makefile
  16. }
  17. src_compile() {
  18. emake CC="$(tc-getCC)" tinlink || die
  19. }
  20. src_install() {
  21. dobin tinlink || die
  22. dodoc AUTHORS README example.asm
  23. }