waf-1.9.8.ebuild 984 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 )
  5. PYTHON_REQ_USE="threads(+)"
  6. inherit python-any-r1 toolchain-funcs
  7. DESCRIPTION="piece of software used to help building software projects"
  8. HOMEPAGE="https://waf.io/"
  9. SRC_URI="https://waf.io/${P}.tar.bz2"
  10. LICENSE="BSD"
  11. SLOT="0"
  12. KEYWORDS="~amd64"
  13. IUSE="examples"
  14. DOCS="ChangeLog README.md DEVEL"
  15. src_prepare() {
  16. rm -v waf || die
  17. default
  18. }
  19. src_configure() {
  20. ${EPYTHON} ./waf-light configure
  21. }
  22. src_compile() {
  23. ${EPYTHON} ./waf-light build
  24. }
  25. src_install() {
  26. default
  27. #point waf binary to waflib dir and strip payload
  28. sed -e "/INSTALL=/s:=.*:='${EROOT}usr':" \
  29. -e "/REVISION=/s:=.*:='${PR}':" \
  30. -e "s:/lib/:/$(get_libdir)/:" \
  31. -e "/^#\(==>\|BZ\|<==\)/d" \
  32. -i waf || die
  33. dobin waf
  34. insinto /usr/$(get_libdir)/${PN}3-${PV}-${PR}
  35. doins -r waflib
  36. if use examples ; then
  37. dodoc -r demos
  38. fi
  39. }