quake1-teamfortress-2.9.ebuild 854 B

12345678910111213141516171819202122232425262728293031323334353637
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils games
  5. DESCRIPTION="The classic Team Fortress Quake World mod"
  6. HOMEPAGE="http://www.planetfortress.com/teamfortress/"
  7. SRC_URI="mirror://gentoo/tf28.zip
  8. mirror://gentoo/tf29qw.zip"
  9. LICENSE="quake1-teamfortress"
  10. SLOT="0"
  11. KEYWORDS="amd64 x86"
  12. IUSE=""
  13. RDEPEND=""
  14. DEPEND="app-arch/unzip"
  15. S=${WORKDIR}
  16. src_unpack() {
  17. echo ">>> Unpacking tf28.zip to ${PWD}"
  18. unzip -qoL "${DISTDIR}"/tf28.zip || die "unpacking tf28.zip failed"
  19. cd fortress
  20. echo ">>> Unpacking tf29qw.zip to ${PWD}"
  21. unzip -qoL "${DISTDIR}"/tf29qw.zip || die "unpacking tf29qw.zip failed"
  22. edos2unix $(find . -name '*.txt' -o -name '*.cfg')
  23. mv server.cfg server.example.cfg
  24. }
  25. src_install() {
  26. insinto "${GAMES_DATADIR}/quake1"
  27. doins -r *
  28. prepgamesdirs
  29. }