crystal-0.2.4.ebuild 793 B

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools eutils games
  5. DESCRIPTION="The crystal MUD client"
  6. HOMEPAGE="http://www.evilmagic.org/crystal/"
  7. SRC_URI="http://www.evilmagic.org/dist/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 ppc x86"
  11. IUSE=""
  12. RDEPEND="sys-libs/zlib
  13. sys-libs/ncurses:0=
  14. dev-libs/openssl:0=
  15. virtual/libiconv"
  16. DEPEND="${RDEPEND}
  17. virtual/pkgconfig"
  18. src_prepare() {
  19. epatch \
  20. "${FILESDIR}"/${P}-gcc43.patch \
  21. "${FILESDIR}"/${P}-build.patch
  22. # avoid colliding with xscreensaver (bug #281191)
  23. mv crystal.6 crystal-mud.6 || die
  24. mv configure.in configure.ac || die
  25. eautoreconf
  26. }
  27. src_configure() {
  28. egamesconf --disable-scripting
  29. }
  30. src_install() {
  31. default
  32. prepgamesdirs
  33. }