lyntin-4.2-r1.ebuild 1.0 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python2_7 )
  5. PYTHON_REQ_USE="tk?"
  6. inherit distutils-r1 games
  7. DESCRIPTION="tintin mud client clone implemented in Python"
  8. HOMEPAGE="http://lyntin.sourceforge.net/"
  9. SRC_URI="mirror://sourceforge/lyntin/${P}.tar.gz"
  10. LICENSE="GPL-3"
  11. SLOT="0"
  12. KEYWORDS="amd64 ppc x86"
  13. IUSE="tk"
  14. DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
  15. RDEPEND=""
  16. DOCS=( COMMANDS PKG-INFO HACKING README )
  17. python_install() {
  18. distutils-r1_python_install --install-scripts="${GAMES_BINDIR}"
  19. }
  20. src_prepare() {
  21. distutils-r1_src_prepare
  22. }
  23. src_compile() {
  24. distutils-r1_src_compile
  25. }
  26. src_install() {
  27. distutils-r1_src_install
  28. prepgamesdirs
  29. }
  30. pkg_postinst() {
  31. games_pkg_postinst
  32. if use tk ; then
  33. elog "To start lyntin in GUI mode, create a config file"
  34. elog "with this in it:"
  35. elog
  36. elog "[Lyntin]"
  37. elog "ui: tk"
  38. elog
  39. elog "Then start lyntin like this:"
  40. elog
  41. elog "runlyntin -c /path/to/config_file\n"
  42. fi
  43. }