tf-50_beta8-r2.ebuild 1.7 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. MY_P="${P/_beta/b}"
  5. DESCRIPTION="A small, flexible, screen-oriented MUD client (aka TinyFugue)"
  6. HOMEPAGE="http://tinyfugue.sourceforge.net/"
  7. SRC_URI="
  8. mirror://sourceforge/tinyfugue/${MY_P}.tar.gz
  9. http://homepage.mac.com/mikeride/abelinc/scripts/allrootpatch.txt -> tf-allrootpatch.txt
  10. http://homepage.mac.com/mikeride/abelinc/scripts/allsrcpatch.txt -> tf-allsrcpatch.txt
  11. doc? ( mirror://sourceforge/tinyfugue/${MY_P}-help.tar.gz )"
  12. LICENSE="GPL-2"
  13. SLOT="0"
  14. KEYWORDS="amd64 ~ppc ~sparc x86"
  15. IUSE="+atcp debug doc +gmcp ipv6 +option102 ssl"
  16. RDEPEND="
  17. ssl? ( dev-libs/openssl:0= )
  18. dev-libs/libpcre"
  19. DEPEND=${RDEPEND}
  20. S=${WORKDIR}/${MY_P}
  21. PATCHES=(
  22. "${DISTDIR}"/tf-allrootpatch.txt
  23. "${DISTDIR}"/tf-allsrcpatch.txt
  24. "${FILESDIR}"/${P}-pcre.patch
  25. "${FILESDIR}"/${P}-stdarg.patch
  26. )
  27. src_configure() {
  28. STRIP=: econf \
  29. $(use_enable atcp) \
  30. $(use_enable gmcp) \
  31. $(use_enable option102) \
  32. $(use_enable ssl) \
  33. $(use_enable debug core) \
  34. $(use_enable ipv6 inet6) \
  35. --enable-manpage
  36. }
  37. src_install() {
  38. dobin src/tf
  39. newman src/tf.1.nroffman tf.1
  40. use doc && HTML_DOCS=( ../${MY_P}-help/{*.html,commands,topics} )
  41. einstalldocs
  42. insinto /usr/share/${PN}-lib
  43. # the application looks for this file here if /changes is called.
  44. # see comments on bug #23274
  45. doins CHANGES
  46. insopts -m0755
  47. doins -r tf-lib/.
  48. }
  49. pkg_postinst() {
  50. if use ipv6; then
  51. ewarn
  52. ewarn "You have merged TinyFugue with IPv6-support."
  53. ewarn "Support for IPv6 is still being experimental."
  54. ewarn "If you experience problems with connecting to hosts,"
  55. ewarn "try re-merging this package with USE="-ipv6""
  56. ewarn
  57. fi
  58. }