tintin-2.01.1.ebuild 738 B

12345678910111213141516171819202122232425262728293031323334353637
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit games
  5. DESCRIPTION="(T)he k(I)cki(N) (T)ickin d(I)kumud clie(N)t"
  6. HOMEPAGE="http://tintin.sourceforge.net/"
  7. SRC_URI="mirror://sourceforge/tintin/${P}.tar.gz"
  8. LICENSE="GPL-2+"
  9. SLOT="0"
  10. KEYWORDS="amd64 ppc x86"
  11. IUSE=""
  12. DEPEND="sys-libs/zlib
  13. net-libs/gnutls
  14. dev-libs/libpcre
  15. sys-libs/readline:0"
  16. RDEPEND=${DEPEND}
  17. S=${WORKDIR}/tt/src
  18. src_install () {
  19. dogamesbin tt++
  20. dodoc ../{CREDITS,FAQ,README,SCRIPTS,TODO,docs/*}
  21. prepgamesdirs
  22. }
  23. pkg_postinst() {
  24. games_pkg_postinst
  25. echo
  26. ewarn "**** OLD TINTIN SCRIPTS ARE NOT 100% COMPATIBLE WITH THIS VERSION ****"
  27. ewarn "read the README for more details."
  28. echo
  29. }