miniracer-1.04.ebuild 899 B

123456789101112131415161718192021222324252627282930313233343536373839404142
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils games
  5. DESCRIPTION="an OpenGL car racing game, based on ID's famous Quake engine"
  6. HOMEPAGE="http://miniracer.sourceforge.net/"
  7. SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="x86"
  11. IUSE=""
  12. RDEPEND="virtual/opengl
  13. x11-libs/libX11
  14. x11-libs/libXext
  15. x11-libs/libXxf86dga
  16. x11-libs/libXxf86vm
  17. media-libs/libsdl
  18. media-libs/sdl-mixer"
  19. DEPEND="${RDEPEND}
  20. x11-proto/xf86dgaproto
  21. x11-proto/xf86vidmodeproto
  22. x11-proto/xproto"
  23. src_prepare() {
  24. epatch "${FILESDIR}"/${P}-nosharedelf.patch \
  25. "${FILESDIR}"/${P}-ldflags.patch
  26. sed -i \
  27. -e "s:@CFLAGS@:${CFLAGS}:" \
  28. -e "s:@GAMES_LIBDIR@:$(games_get_libdir)/${PN}:" \
  29. -e "s:@GAMES_BINDIR@:${GAMES_BINDIR}:" \
  30. miniracer Makefile || die
  31. }
  32. src_install() {
  33. default
  34. prepgamesdirs
  35. }