warmux-11.04.1.ebuild 1.4 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools eutils games
  5. DESCRIPTION="A free Worms clone"
  6. HOMEPAGE="http://gna.org/projects/warmux/"
  7. SRC_URI="http://download.gna.org/warmux/${P}.tar.bz2"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 ~ppc x86 ~amd64-linux ~x86-linux ~x86-solaris"
  11. IUSE="debug nls unicode"
  12. RDEPEND="media-libs/libsdl[joystick,video,X]
  13. media-libs/sdl-image[jpeg,png]
  14. media-libs/sdl-mixer[vorbis]
  15. media-libs/sdl-ttf
  16. media-libs/sdl-net
  17. >=media-libs/sdl-gfx-2.0.22
  18. net-misc/curl
  19. media-fonts/dejavu
  20. dev-libs/libxml2
  21. x11-libs/libX11
  22. nls? ( virtual/libintl )
  23. unicode? ( dev-libs/fribidi )"
  24. DEPEND="${RDEPEND}
  25. virtual/pkgconfig
  26. nls? ( sys-devel/gettext )"
  27. S=${WORKDIR}/${PN}-11.04
  28. src_prepare() {
  29. epatch \
  30. "${FILESDIR}"/${P}-gentoo.patch \
  31. "${FILESDIR}"/${P}-zlib.patch \
  32. "${FILESDIR}"/${P}-action.patch \
  33. "${FILESDIR}"/${P}-gcc47.patch \
  34. "${FILESDIR}"/${P}-stat.patch
  35. eautoreconf
  36. }
  37. src_configure() {
  38. egamesconf \
  39. --with-localedir-name=/usr/share/locale \
  40. --with-datadir-name="${GAMES_DATADIR}/${PN}" \
  41. --with-font-path=/usr/share/fonts/dejavu/DejaVuSans.ttf \
  42. $(use_enable debug) \
  43. $(use_enable nls) \
  44. $(use_enable unicode fribidi)
  45. }
  46. src_install() {
  47. default
  48. rm -f "${D}${GAMES_DATADIR}/${PN}/font/DejaVuSans.ttf"
  49. doicon data/icon/warmux.svg
  50. make_desktop_entry warmux Warmux
  51. prepgamesdirs
  52. }