khmer-5.0-r1.ebuild 721 B

123456789101112131415161718192021222324252627282930313233343536
  1. # Copyright 1999-2010 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit font
  4. DESCRIPTION="Fonts for the Khmer language of Cambodia"
  5. HOMEPAGE="http://www.khmeros.info/drupal/?q=en/download/fonts"
  6. SRC_URI="mirror://sourceforge/khmer/All_KhmerOS_${PV}.zip"
  7. LICENSE="LGPL-2.1"
  8. SLOT="0"
  9. KEYWORDS="amd64 x86"
  10. IUSE=""
  11. DEPEND="app-arch/unzip"
  12. RDEPEND=""
  13. S="${WORKDIR}/All_KhmerOS_${PV}"
  14. FONT_S="${S}"
  15. FONT_SUFFIX="ttf"
  16. src_unpack() {
  17. unpack ${A}
  18. cd "${S}"
  19. [[ -f "KhmerOS .ttf" ]] && mv "KhmerOS .ttf" "KhmerOS.ttf" # 338057
  20. }
  21. pkg_postinst() {
  22. font_pkg_postinst
  23. echo
  24. elog "To prefer using Khmer OS fonts, run:"
  25. elog
  26. elog " eselect fontconfig enable 65-khmer.conf"
  27. echo
  28. }