fotoxx-13.11.1.ebuild 1.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit eutils toolchain-funcs fdo-mime
  5. DESCRIPTION="Program for improving image files made with a digital camera"
  6. HOMEPAGE="http://www.kornelix.com/fotoxx.html"
  7. SRC_URI="http://www.kornelix.com/uploads/1/3/0/3/13035936/${P}.tar.gz"
  8. LICENSE="GPL-3"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86"
  11. IUSE=""
  12. DEPEND="
  13. x11-libs/gtk+:3
  14. media-libs/libpng
  15. media-libs/tiff
  16. media-libs/lcms:2"
  17. RDEPEND="${DEPEND}
  18. media-libs/exiftool
  19. media-gfx/ufraw[gtk]
  20. media-gfx/dcraw
  21. x11-misc/xdg-utils"
  22. src_prepare() {
  23. epatch "${FILESDIR}"/${PF}.patch
  24. }
  25. src_compile() {
  26. tc-export CXX
  27. emake
  28. }
  29. src_install() {
  30. # For the Help menu items to work, *.html must be in /usr/share/doc/${PF},
  31. # and README, changelog, translations, edit-menus, KB-shortcuts must not be compressed
  32. emake DESTDIR="${D}" install
  33. newmenu desktop ${PN}.desktop
  34. rm -f "${D}"/usr/share/doc/${PF}/*.man
  35. docompress -x /usr/share/doc
  36. }
  37. pkg_postinst() {
  38. fdo-mime_mime_database_update
  39. fdo-mime_desktop_database_update
  40. }
  41. pkg_postrm() {
  42. fdo-mime_desktop_database_update
  43. fdo-mime_mime_database_update
  44. }