1234567891011121314151617181920212223242526272829303132333435 |
- # Copyright 1999-2014 Gentoo Foundation
- # Distributed under the terms of the GNU General Public License v2
- EAPI="5"
- inherit toolchain-funcs eutils
- DESCRIPTION="create an APNG from a GIF"
- HOMEPAGE="https://sourceforge.net/projects/gif2apng/"
- SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}-src.zip"
- LICENSE="LGPL-2.1"
- SLOT="0"
- KEYWORDS="~amd64 ~x86"
- IUSE=""
- RDEPEND="sys-libs/zlib"
- DEPEND="${RDEPEND}
- app-arch/unzip"
- S=${WORKDIR}
- src_prepare() {
- epatch "${FILESDIR}"/${P}-flags.patch
- }
- src_compile() {
- emake CC="$(tc-getCC)"
- }
- src_install() {
- dobin ${PN}
- dodoc readme.txt
- }
|