gif2apng-1.9.ebuild 586 B

1234567891011121314151617181920212223242526272829303132333435
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. inherit toolchain-funcs eutils
  5. DESCRIPTION="create an APNG from a GIF"
  6. HOMEPAGE="https://sourceforge.net/projects/gif2apng/"
  7. SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}-src.zip"
  8. LICENSE="LGPL-2.1"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE=""
  12. RDEPEND="sys-libs/zlib"
  13. DEPEND="${RDEPEND}
  14. app-arch/unzip"
  15. S=${WORKDIR}
  16. src_prepare() {
  17. epatch "${FILESDIR}"/${P}-flags.patch
  18. }
  19. src_compile() {
  20. emake CC="$(tc-getCC)"
  21. }
  22. src_install() {
  23. dobin ${PN}
  24. dodoc readme.txt
  25. }