gifsicle-1.78.ebuild 653 B

12345678910111213141516171819202122232425
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. DESCRIPTION="A command-line tool for creating, editing, and getting information about GIF images and animations"
  5. HOMEPAGE="http://www.lcdf.org/~eddietwo/gifsicle/"
  6. SRC_URI="http://www.lcdf.org/~eddietwo/${PN}/${P}.tar.gz"
  7. LICENSE="GPL-2 MIT"
  8. SLOT="0"
  9. KEYWORDS="~alpha amd64 ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
  10. IUSE="X"
  11. RDEPEND="X? ( x11-libs/libX11 x11-libs/libXt )"
  12. DEPEND="${RDEPEND}
  13. X? ( x11-proto/xproto )"
  14. src_configure() {
  15. local myconf
  16. use X || myconf='--disable-gifview'
  17. econf ${myconf}
  18. }