mandelbulber-1.11.ebuild 853 B

12345678910111213141516171819202122232425262728293031323334353637383940414243444546
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit eutils toolchain-funcs
  5. MY_P=${PN}${PV}
  6. DESCRIPTION="Tool to render 3D fractals"
  7. HOMEPAGE="https://sites.google.com/site/mandelbulber/home"
  8. SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
  9. LICENSE="GPL-3"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86"
  12. IUSE=""
  13. RDEPEND="x11-libs/gtk+:2
  14. >=media-libs/libsndfile-1
  15. >=media-libs/libpng-1.4
  16. virtual/jpeg"
  17. DEPEND="${RDEPEND}
  18. virtual/pkgconfig"
  19. S=${WORKDIR}/${MY_P}
  20. src_prepare() {
  21. epatch "${FILESDIR}"/${P}-qa.patch
  22. }
  23. src_compile() {
  24. emake CXX="$(tc-getCXX)" -C makefiles all
  25. }
  26. src_install() {
  27. dobin makefiles/${PN}
  28. dodoc README NEWS
  29. insinto /usr/share/${PN}
  30. doins -r usr/share/*
  31. }
  32. pkg_postinst() {
  33. elog "Before you run ${PN} please copy /usr/share/${PN}/* to \${HOME}/.${PN}"
  34. }