neocon-20110228.ebuild 507 B

12345678910111213141516171819202122232425
  1. # Copyright 1999-2011 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit toolchain-funcs
  5. DESCRIPTION="A simple serial console utility that tries to open ttys repeatedly"
  6. HOMEPAGE="http://wiki.openmoko.org/wiki/NeoCon"
  7. SRC_URI="https://dev.gentoo.org/~radhermit/distfiles/${P}.tar.bz2"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE=""
  12. src_compile() {
  13. emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" all
  14. }
  15. src_install() {
  16. dobin neocon
  17. dodoc README
  18. }