picocom-2.1.ebuild 788 B

123456789101112131415161718192021222324252627282930
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit toolchain-funcs
  5. DESCRIPTION="minimal dumb-terminal emulation program"
  6. HOMEPAGE="https://github.com/npat-efault/picocom"
  7. SRC_URI="https://github.com/npat-efault/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 ~ppc ~sparc x86 ~x86-fbsd"
  11. IUSE=""
  12. src_compile() {
  13. # CPPFLAGS is shared between CFLAGS and CXXFLAGS, but there is no
  14. # C++ file, and the pre-processor is never called directly, this
  15. # is easier than patching it out.
  16. emake LDFLAGS="${LDFLAGS}" CFLAGS="${CFLAGS} ${CPPFLAGS} -Wall" \
  17. CC="$(tc-getCC)"
  18. }
  19. src_install() {
  20. dobin picocom pc{asc,xm,ym,zm}
  21. doman picocom.1
  22. dodoc CHANGES.old CONTRIBUTORS README.md
  23. }