fwbuilder-5.3.6.ebuild 961 B

12345678910111213141516171819202122232425262728293031323334353637383940414243444546
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="6"
  4. inherit qmake-utils autotools
  5. DESCRIPTION="A firewall GUI"
  6. HOMEPAGE="http://www.fwbuilder.org/"
  7. SRC_URI="https://github.com/UNINETT/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~ppc64 ~x86"
  11. IUSE="libressl"
  12. DEPEND="
  13. !libressl? ( dev-libs/openssl:0 )
  14. libressl? ( dev-libs/libressl )
  15. dev-libs/elfutils
  16. >=dev-qt/qtgui-5.5.1-r1:5"
  17. RDEPEND="${DEPEND}"
  18. src_prepare() {
  19. eapply_user
  20. sed -i -e '/dnl.*AM_INIT_AUTOMAKE/d' configure.in || die #398743
  21. mv configure.in configure.ac || die #426262
  22. eautoreconf
  23. }
  24. src_configure() {
  25. eqmake5
  26. # portage handles ccache/distcc itself
  27. econf --without-{ccache,distcc}
  28. }
  29. src_install() {
  30. emake INSTALL_ROOT="${D}" install
  31. }
  32. pkg_postinst() {
  33. validate_desktop_entries
  34. elog "You need to emerge sys-apps/iproute2"
  35. elog "in order to run the firewall script."
  36. }