ircii-20110228.ebuild 888 B

123456789101112131415161718192021222324252627282930313233343536373839
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit eutils toolchain-funcs
  5. DESCRIPTION="An IRC and ICB client that runs under most UNIX platforms"
  6. SRC_URI="ftp://ircii.warped.com/pub/ircII/${P}.tar.bz2"
  7. HOMEPAGE="http://www.eterna.com.au/ircii/"
  8. SLOT="0"
  9. LICENSE="BSD"
  10. KEYWORDS="amd64 ~ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
  11. IUSE="ipv6"
  12. DEPEND="sys-libs/ncurses
  13. virtual/libiconv"
  14. # This and irc-client both install /usr/bin/irc #247987
  15. RDEPEND="${DEPEND}
  16. !!net-irc/irc-client"
  17. src_prepare() {
  18. epatch "${FILESDIR}"/${P}-glibc.patch
  19. }
  20. src_configure() {
  21. tc-export CC
  22. use elibc_glibc || append-libs -liconv
  23. econf $(use_enable ipv6)
  24. }
  25. src_install() {
  26. emake -j1 DESTDIR="${D}" install
  27. dodoc ChangeLog INSTALL NEWS README \
  28. doc/Copyright doc/crypto doc/VERSIONS doc/ctcp
  29. }