pisg-0.73-r1.ebuild 979 B

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit perl-module
  5. DESCRIPTION="Perl IRC Statistics Generator"
  6. HOMEPAGE="http://pisg.sourceforge.net/"
  7. SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 ppc x86 ~x86-fbsd"
  11. IUSE=""
  12. RDEPEND="dev-perl/Text-Iconv"
  13. DEPEND=">=sys-apps/sed-4"
  14. src_prepare() {
  15. sed -i \
  16. -e 's!lang\.txt!/usr/share/pisg/lang.txt!' \
  17. -e 's!layout/!/usr/share/pisg/layout/!' \
  18. modules/Pisg.pm || die "sed failed"
  19. }
  20. src_compile() {
  21. einfo "Nothing to compile"
  22. }
  23. src_install() {
  24. perl_set_version
  25. dobin pisg || die "dobin failed"
  26. insinto "${VENDOR_LIB}"
  27. doins -r modules/.
  28. insinto /usr/share/pisg
  29. doins -r gfx layout lang.txt
  30. dodoc docs/{FORMATS,pisg-doc.txt} \
  31. docs/dev/API pisg.cfg README
  32. doman docs/pisg.1
  33. dohtml docs/pisg-doc.html
  34. }
  35. pkg_postinst() {
  36. einfo "The pisg images have been installed in /usr/share/pisg/gfx"
  37. }