redirbot-0.0.5-r1.ebuild 667 B

1234567891011121314151617181920212223242526272829
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python2_7 )
  5. DOCS=( ChangeLog README.rst )
  6. inherit distutils-r1
  7. DESCRIPTION="IRCBot, telling people they should contact you on different nickname"
  8. HOMEPAGE="https://github.com/yaccz/redirbot"
  9. SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
  10. LICENSE="BSD"
  11. SLOT="0"
  12. KEYWORDS="~amd64 ~x86"
  13. IUSE=""
  14. DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
  15. || (
  16. >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
  17. ( >=dev-python/twisted-core-11.1.0[${PYTHON_USEDEP}]
  18. dev-python/twisted-words[${PYTHON_USEDEP}]
  19. )
  20. )
  21. "
  22. RDEPEND="${DEPEND}"