scrollz-2.2.ebuild 1.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit eutils toolchain-funcs
  5. MY_P=ScrollZ-${PV}
  6. DESCRIPTION="Advanced IRC client based on ircII"
  7. HOMEPAGE="http://scrollz.com/"
  8. SRC_URI="http://www.scrollz.com/download/${MY_P}.tar.gz"
  9. LICENSE="BSD"
  10. SLOT="0"
  11. KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
  12. IUSE="gmp gnutls ipv6 socks5 ssl"
  13. REQUIRED_USE="gnutls? ( ssl )"
  14. RDEPEND="sys-libs/ncurses
  15. gmp? ( dev-libs/gmp )
  16. ssl? (
  17. gnutls? ( net-libs/gnutls )
  18. !gnutls? ( dev-libs/openssl )
  19. )"
  20. DEPEND="${RDEPEND}
  21. virtual/pkgconfig"
  22. S=${WORKDIR}/${MY_P}
  23. src_prepare() {
  24. epatch "${FILESDIR}"/${P}-cppflags.patch
  25. epatch "${FILESDIR}"/${P}-make-install.patch
  26. }
  27. src_configure() {
  28. local _myssl
  29. if use ssl; then
  30. if use gnutls; then
  31. _myssl="--with-ssl"
  32. else
  33. _myssl="--with-openssl"
  34. fi
  35. fi
  36. tc-export CC #397441, ancient autoconf
  37. econf \
  38. --with-default-server=irc.gentoo.org \
  39. $(use_enable socks5) \
  40. $(use_enable ipv6) \
  41. --enable-regexp \
  42. $(use_enable gmp fish) \
  43. ${_myssl}
  44. }
  45. src_install() {
  46. emake \
  47. DESTDIR="${D}" \
  48. mandir="${EPREFIX}/usr/share/man/man1" \
  49. install
  50. dodoc ChangeLog* NEWS README* todo
  51. }