libgmail-0.1.11-r1.ebuild 601 B

123456789101112131415161718192021222324252627
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python2_7 )
  5. DISTUTILS_SINGLE_IMPL=1
  6. inherit distutils-r1
  7. DESCRIPTION="Python bindings to access Google's gmail service"
  8. HOMEPAGE="http://libgmail.sourceforge.net/"
  9. SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
  10. LICENSE="GPL-2"
  11. SLOT="0"
  12. KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
  13. IUSE=""
  14. DEPEND="dev-python/clientcookie[${PYTHON_USEDEP}]
  15. dev-python/mechanize[${PYTHON_USEDEP}]"
  16. RDEPEND="${DEPEND}"
  17. pkg_setup() {
  18. python-single-r1_pkg_setup
  19. }