libnxml-0.18.3.ebuild 884 B

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="4"
  4. DESCRIPTION="A C-library for parsing and writing XML 1.0/1.1 files or streams"
  5. HOMEPAGE="http://www.autistici.org/bakunin/libnxml/doc/"
  6. SRC_URI="http://www.autistici.org/bakunin/${PN}/${P}.tar.gz"
  7. LICENSE="LGPL-2.1"
  8. SLOT="0"
  9. KEYWORDS="amd64 ~arm ~mips ppc ~sparc x86"
  10. IUSE="doc examples static-libs"
  11. RDEPEND="net-misc/curl"
  12. DEPEND="${RDEPEND}
  13. doc? ( app-doc/doxygen )"
  14. src_configure() {
  15. econf \
  16. $(use_enable static-libs static)
  17. }
  18. src_compile() {
  19. emake
  20. if use doc; then
  21. ebegin "Creating documentation"
  22. doxygen doxy.conf || die "creating docs failed"
  23. eend 0
  24. fi
  25. }
  26. src_install() {
  27. default
  28. if use doc; then
  29. dohtml doc/html/*
  30. fi
  31. if use examples; then
  32. insinto /usr/share/doc/${PF}/test
  33. doins test/*.c
  34. fi
  35. find "${D}" -name '*.la' -delete
  36. }