ed2k_hash-0.4.0-r2.ebuild 816 B

1234567891011121314151617181920212223242526272829303132333435363738
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit flag-o-matic
  5. DESCRIPTION="Tool for generating eDonkey2000 links"
  6. HOMEPAGE="http://ed2k-tools.sourceforge.net/ed2k_hash.shtml"
  7. RESTRICT="mirror"
  8. SRC_URI="mirror://sourceforge/ed2k-tools/${P}.tar.gz"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~ppc ~sparc ~x86"
  12. IUSE="" # fltk support is broken, bug #359643
  13. DEPEND=""
  14. RDEPEND=""
  15. #DEPEND="fltk? ( x11-libs/fltk:1 )"
  16. PATCHES=( "${FILESDIR}/ed2k_64bit.patch" )
  17. src_configure() {
  18. # if use fltk; then
  19. # append-ldflags "$(fltk-config --ldflags)"
  20. # export CPPFLAGS="$(fltk-config --cxxflags)"
  21. # else
  22. export ac_cv_lib_fltk_main='no'
  23. # fi
  24. econf
  25. }
  26. src_install() {
  27. emake install DESTDIR="${D}" mydocdir=/usr/share/doc/${PF}/html
  28. einstalldocs
  29. }