cntlm-0.93_beta5-r2.ebuild 1.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit eutils systemd toolchain-funcs user
  5. DESCRIPTION="Cntlm is an NTLM/NTLMv2 authenticating HTTP proxy"
  6. HOMEPAGE="http://cntlm.sourceforge.net/"
  7. SRC_URI="http://ftp.awk.cz/pub/${P//_}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE=""
  12. DEPEND=""
  13. RDEPEND=""
  14. S="${WORKDIR}/${P//_}"
  15. src_prepare() {
  16. eapply -p0 "${FILESDIR}"/${P}-buildsystem.patch # 334647
  17. default
  18. }
  19. src_configure() {
  20. tc-export CC
  21. econf
  22. # Replace default config file path in Makefile
  23. sed -i -e 's~SYSCONFDIR=/usr/local/etc~SYSCONFDIR=/etc~' \
  24. "${S}"/Makefile || die "sed failed"
  25. }
  26. src_compile() {
  27. emake V=1
  28. }
  29. src_install() {
  30. dobin cntlm
  31. dodoc COPYRIGHT README VERSION doc/cntlm.conf
  32. doman doc/cntlm.1
  33. newinitd "${FILESDIR}"/cntlm.initd cntlm
  34. newconfd "${FILESDIR}"/cntlm.confd cntlm
  35. systemd_dounit "${FILESDIR}"/cntlm.service
  36. insinto /etc
  37. insopts -m0600
  38. doins doc/cntlm.conf
  39. }
  40. pkg_postinst() {
  41. enewgroup cntlm
  42. enewuser cntlm -1 -1 -1 cntlm
  43. }