123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657 |
- # Copyright 1999-2016 Gentoo Foundation
- # Distributed under the terms of the GNU General Public License v2
- EAPI=6
- inherit eutils systemd toolchain-funcs user
- DESCRIPTION="Cntlm is an NTLM/NTLMv2 authenticating HTTP proxy"
- HOMEPAGE="http://cntlm.sourceforge.net/"
- SRC_URI="http://ftp.awk.cz/pub/${P//_}.tar.gz"
- LICENSE="GPL-2"
- SLOT="0"
- KEYWORDS="~amd64 ~x86"
- IUSE=""
- DEPEND=""
- RDEPEND=""
- S="${WORKDIR}/${P//_}"
- src_prepare() {
- eapply -p0 "${FILESDIR}"/${P}-buildsystem.patch # 334647
- default
- }
- src_configure() {
- tc-export CC
- econf
- # Replace default config file path in Makefile
- sed -i -e 's~SYSCONFDIR=/usr/local/etc~SYSCONFDIR=/etc~' \
- "${S}"/Makefile || die "sed failed"
- }
- src_compile() {
- emake V=1
- }
- src_install() {
- dobin cntlm
- dodoc COPYRIGHT README VERSION doc/cntlm.conf
- doman doc/cntlm.1
- newinitd "${FILESDIR}"/cntlm.initd cntlm
- newconfd "${FILESDIR}"/cntlm.confd cntlm
- systemd_dounit "${FILESDIR}"/cntlm.service
- insinto /etc
- insopts -m0600
- doins doc/cntlm.conf
- }
- pkg_postinst() {
- enewgroup cntlm
- enewuser cntlm -1 -1 -1 cntlm
- }
|