obfsproxy-0.2.13.ebuild 752 B

123456789101112131415161718192021222324252627
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit distutils-r1
  6. DESCRIPTION="An obfuscating proxy using Tor's pluggable transport protocol"
  7. HOMEPAGE="https://www.torproject.org/projects/obfsproxy.html"
  8. SRC_URI="mirror://pypi/o/${PN}/${P}.tar.gz"
  9. LICENSE="BSD"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~mips ~x86"
  12. DOCS=( ChangeLog INSTALL README TODO doc/HOWTO.txt )
  13. DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
  14. RDEPEND=">=dev-python/pyptlib-0.0.6[${PYTHON_USEDEP}]
  15. >=dev-python/pycrypto-2.6-r2[${PYTHON_USEDEP}]
  16. dev-python/twisted-core[${PYTHON_USEDEP}]
  17. dev-python/pyyaml[${PYTHON_USEDEP}]"
  18. PATCHES=( "${FILESDIR}"/${PN}-0.2.9-remove-argparse.patch )