htun-0.9.6.ebuild 947 B

12345678910111213141516171819202122232425262728293031323334353637383940414243444546
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit flag-o-matic readme.gentoo-r1 toolchain-funcs
  5. DESCRIPTION="Project to tunnel IP traffic over HTTP"
  6. HOMEPAGE="http://linux.softpedia.com/get/System/Networking/HTun-14751.shtml"
  7. SRC_URI="http://www.sourcefiles.org/Networking/Tools/Proxy/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. # should not be replaced by virtual/yacc
  12. # at least failed with dev-util/bison
  13. DEPEND="dev-util/yacc"
  14. RDEPEND=""
  15. PATCHES=(
  16. "${FILESDIR}"/${P}-glibc.patch #248100
  17. "${FILESDIR}"/${P}-makefile.patch
  18. )
  19. src_configure() {
  20. # Fix multiple symbol definitions due to
  21. # C99/C11 inline semantics, bug 571458
  22. append-cflags -std=gnu89
  23. }
  24. src_compile() {
  25. emake -C src CC="$(tc-getCC)"
  26. }
  27. src_install() {
  28. dosbin src/htund
  29. insinto /etc
  30. doins doc/htund.conf
  31. local DOCS=( doc/. README )
  32. einstalldocs
  33. readme.gentoo_create_doc
  34. }