image_pipeline-1.12.19.ebuild 583 B

1234567891011121314151617181920212223242526
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. ROS_REPO_URI="https://github.com/ros-perception/image_pipeline"
  5. KEYWORDS="~amd64 ~arm"
  6. ROS_SUBDIR=${PN}
  7. inherit ros-catkin
  8. DESCRIPTION="Fills the gap between getting raw images from a camera driver and higher-level vision processing"
  9. LICENSE="BSD"
  10. SLOT="0"
  11. IUSE=""
  12. RDEPEND="
  13. dev-ros/camera_calibration
  14. dev-ros/depth_image_proc
  15. dev-ros/image_proc
  16. dev-ros/image_publisher
  17. dev-ros/image_rotate
  18. dev-ros/image_view
  19. dev-ros/stereo_image_proc
  20. "
  21. DEPEND="${RDEPEND}"