erfa-1.3.0.ebuild 573 B

12345678910111213141516171819202122232425262728293031
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit autotools eutils
  5. DESCRIPTION="Essential Routines for Fundamental Astronomy"
  6. HOMEPAGE="https://github.com/liberfa/erfa"
  7. SRC_URI="https://github.com/liberfa/erfa/releases/download/v${PV}/${P}.tar.gz"
  8. LICENSE="BSD"
  9. SLOT="0/1"
  10. KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
  11. IUSE="static-libs"
  12. src_prepare() {
  13. default
  14. eautoreconf
  15. }
  16. src_configure() {
  17. econf $(use_enable static-libs static)
  18. }
  19. src_install() {
  20. default
  21. prune_libtool_files --all
  22. }