kapteyn-2.3.ebuild 775 B

12345678910111213141516171819202122232425262728293031323334
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit distutils-r1
  6. DESCRIPTION="Collection of python tools for astronomy"
  7. HOMEPAGE="http://www.astro.rug.nl/software/kapteyn"
  8. SRC_URI="http://www.astro.rug.nl/software/kapteyn/${P}.tar.gz"
  9. LICENSE="BSD"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
  12. IUSE=""
  13. DEPEND="
  14. sci-astronomy/wcslib
  15. dev-python/numpy[${PYTHON_USEDEP}]"
  16. RDEPEND="${DEPEND}
  17. dev-python/astropy[${PYTHON_USEDEP}]
  18. dev-python/matplotlib[${PYTHON_USEDEP}]"
  19. DOCS=( CHANGES.txt README.txt doc/${PN}.pdf )
  20. PATCHES=( "${FILESDIR}"/${PN}-2.2-debundle_wcs.patch )
  21. python_prepare_all() {
  22. rm -r src/wcslib-4.* || die
  23. distutils-r1_python_prepare_all
  24. }