express-1.5.1.ebuild 706 B

12345678910111213141516171819202122232425262728293031323334353637
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit cmake-utils
  5. DESCRIPTION="Streaming RNA-Seq Analysis"
  6. HOMEPAGE="http://bio.math.berkeley.edu/eXpress/"
  7. SRC_URI="http://bio.math.berkeley.edu/eXpress/downloads/${P}/${P}-src.tgz"
  8. LICENSE="Artistic"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE=""
  12. DEPEND="
  13. >=dev-libs/boost-1.52.0:=
  14. dev-libs/protobuf
  15. dev-util/google-perftools
  16. sys-libs/zlib
  17. sci-biology/bamtools"
  18. RDEPEND="${DEPEND}"
  19. S="${WORKDIR}/${P}-src"
  20. PATCHES=(
  21. "${FILESDIR}"/${P}-buildsystem.patch
  22. )
  23. src_configure() {
  24. local mycmakeargs=(
  25. -DBAMTOOLS_INCLUDE="${EPREFIX}/usr/include/bamtools"
  26. )
  27. cmake-utils_src_configure
  28. }