gato-1.2.2.ebuild 807 B

1234567891011121314151617181920212223242526272829303132333435363738
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. PYTHON_COMPAT=( python2_7 )
  5. PYTHON_REQ_USE="tk(+)"
  6. inherit distutils-r1
  7. DESCRIPTION="Graph Animation Toolbox"
  8. HOMEPAGE="http://gato.sourceforge.net/"
  9. SRC_URI="mirror://sourceforge/${PN}/${P^}.tar.gz"
  10. LICENSE="LGPL-2"
  11. SLOT="0"
  12. KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
  13. IUSE=""
  14. S="${WORKDIR}/${P^}"
  15. python_prepare_all() {
  16. # change TKinter call to avoid crashing of X
  17. sed -i \
  18. -e 's:self.overrideredirect(1):self.overrideredirect(0):' \
  19. "${S}"/GatoDialogs.py || die "failed to patch GatoDialogs.py"
  20. distutils-r1_python_prepare_all
  21. }
  22. python_install_all() {
  23. distutils-r1_python_install_all
  24. # install data files
  25. insinto /usr/share/${PN}
  26. doins BFS.* DFS.* sample.cat
  27. }