efibootmgr-14.ebuild 598 B

1234567891011121314151617181920212223242526272829
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit toolchain-funcs
  5. DESCRIPTION="User-space application to modify the EFI boot manager"
  6. HOMEPAGE="https://github.com/rhinstaller/efibootmgr"
  7. SRC_URI="https://github.com/rhinstaller/efibootmgr/releases/download/${PV}/${P}.tar.bz2"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 ~arm64 ia64 x86"
  11. IUSE=""
  12. RDEPEND="sys-apps/pciutils
  13. >=sys-libs/efivar-25:="
  14. DEPEND="${RDEPEND}"
  15. src_prepare() {
  16. default
  17. sed -i -e s/-Werror// Make.defaults || die
  18. }
  19. src_configure() {
  20. tc-export CC
  21. }