automake-1.6.3-r2.ebuild 2.0 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="4"
  4. inherit eutils
  5. DESCRIPTION="Used to generate Makefile.in from Makefile.am"
  6. HOMEPAGE="https://www.gnu.org/software/automake/"
  7. SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
  8. LICENSE="GPL-2"
  9. # Use Gentoo versioning for slotting.
  10. SLOT="${PV:0:3}"
  11. KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
  12. IUSE=""
  13. RDEPEND="dev-lang/perl
  14. >=sys-devel/automake-wrapper-10
  15. >=sys-devel/autoconf-2.69
  16. sys-devel/gnuconfig"
  17. DEPEND="${RDEPEND}"
  18. src_prepare() {
  19. export WANT_AUTOCONF=2.5
  20. epatch "${FILESDIR}"/${P}-test-fixes.patch #159557
  21. epatch "${FILESDIR}"/${PN}-1.10-ccnoco-ldflags.patch #203914
  22. epatch "${FILESDIR}"/${PN}-1.5-CVE-2009-4029.patch #295357
  23. epatch "${FILESDIR}"/${PN}-1.5-perl-5.11.patch
  24. }
  25. # slot the info pages. do this w/out munging the source so we don't have
  26. # to depend on texinfo to regen things. #464146 (among others)
  27. slot_info_pages() {
  28. pushd "${ED}"/usr/share/info >/dev/null
  29. rm -f dir
  30. # Rewrite all the references to other pages.
  31. # before: * aclocal-invocation: (automake)aclocal Invocation. Generating aclocal.m4.
  32. # after: * aclocal-invocation v1.13: (automake-1.13)aclocal Invocation. Generating aclocal.m4.
  33. local p pages=( *.info ) args=()
  34. for p in "${pages[@]/%.info}" ; do
  35. args+=(
  36. -e "/START-INFO-DIR-ENTRY/,/END-INFO-DIR-ENTRY/s|: (${p})| v${SLOT}&|"
  37. -e "s:(${p}):(${p}-${SLOT}):g"
  38. )
  39. done
  40. sed -i "${args[@]}" * || die
  41. # Rewrite all the file references, and rename them in the process.
  42. local f d
  43. for f in * ; do
  44. d=${f/.info/-${SLOT}.info}
  45. mv "${f}" "${d}" || die
  46. sed -i -e "s:${f}:${d}:g" * || die
  47. done
  48. popd >/dev/null
  49. }
  50. src_install() {
  51. default
  52. slot_info_pages
  53. rm -f "${ED}"/usr/bin/{aclocal,automake}
  54. # remove all config.guess and config.sub files replacing them
  55. # w/a symlink to a specific gnuconfig version
  56. local x
  57. for x in guess sub ; do
  58. dosym ../gnuconfig/config.${x} /usr/share/${PN}-${SLOT}/config.${x}
  59. done
  60. }