qconf-2.3.ebuild 968 B

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit qmake-utils
  5. DESCRIPTION="./configure like generator for qmake-based projects"
  6. HOMEPAGE="https://github.com/psi-plus/qconf"
  7. SRC_URI="http://psi-im.org/files/qconf/${P}.tar.xz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
  11. IUSE="qt4 +qt5"
  12. # There is no one to one match to autotools-based configure
  13. QA_CONFIGURE_OPTIONS=".*"
  14. RDEPEND="
  15. qt4? ( dev-qt/qtcore:4 )
  16. qt5? (
  17. dev-qt/qtcore:5
  18. dev-qt/qtxml:5
  19. )
  20. "
  21. DEPEND="${RDEPEND}"
  22. REQUIRED_USE="^^ ( qt4 qt5 )"
  23. src_configure() {
  24. use qt4 && QTVERSION=4
  25. use qt5 && QTVERSION=5
  26. econf \
  27. --qtselect="${QTVERSION}" \
  28. --extraconf=QMAKE_STRIP= \
  29. --verbose || die
  30. # just to set all the Gentoo toolchain flags
  31. eqmake${QTVERSION}
  32. }
  33. src_install() {
  34. emake INSTALL_ROOT="${D}" install
  35. einstalldocs
  36. insinto /usr/share/doc/${PF}
  37. doins -r examples
  38. }