argp-standalone-1.3-r1.ebuild 664 B

12345678910111213141516171819202122232425262728293031323334
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. inherit eutils flag-o-matic
  5. DESCRIPTION="Standalone argp library for use with uclibc"
  6. HOMEPAGE="http://www.lysator.liu.se/~nisse/misc/"
  7. SRC_URI="http://www.lysator.liu.se/~nisse/misc/argp-standalone-1.3.tar.gz"
  8. LICENSE="public-domain"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~arm ~arm64 ~m68k ~mips ~ppc ~s390 ~sh ~x86"
  11. IUSE=""
  12. DEPEND="!sys-libs/glibc"
  13. src_prepare() {
  14. epatch "${FILESDIR}/${P}-throw-in-funcdef.patch"
  15. }
  16. src_configure() {
  17. append-cflags -fgnu89-inline
  18. default
  19. }
  20. src_install() {
  21. dolib.a libargp.a
  22. insinto /usr/include
  23. doins argp.h
  24. }