ntdb-1.0-r1.ebuild 1.1 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python2_7 )
  5. PYTHON_REQ_USE="threads(+)"
  6. inherit waf-utils multilib-minimal python-single-r1
  7. DESCRIPTION="A not-so trivial keyword/data database system"
  8. HOMEPAGE="http://tdb.samba.org/"
  9. SRC_URI="http://samba.org/ftp/tdb/${P}.tar.gz"
  10. LICENSE="GPL-3"
  11. SLOT="0"
  12. KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 sparc x86"
  13. IUSE="python"
  14. REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
  15. RDEPEND="python? ( ${PYTHON_DEPS} )"
  16. DEPEND="!<net-fs/samba-4.1.7
  17. ${RDEPEND}
  18. ${PYTHON_DEPS}
  19. app-text/docbook-xml-dtd:4.2"
  20. WAF_BINARY="${S}/buildtools/bin/waf"
  21. src_prepare() {
  22. multilib_copy_sources
  23. }
  24. multilib_src_configure() {
  25. local extra_opts=()
  26. if ! multilib_is_native_abi || ! use python; then
  27. extra_opts+=( --disable-python )
  28. fi
  29. waf-utils_src_configure \
  30. "${extra_opts[@]}"
  31. }
  32. multilib_src_test() {
  33. # the default src_test runs 'make test' and 'make check', letting
  34. # the tests fail occasionally (reason: unknown)
  35. emake check
  36. }
  37. multilib_src_install() {
  38. waf-utils_src_install
  39. }