uid_wrapper-1.2.1.ebuild 1.1 KB

1234567891011121314151617181920212223242526272829303132
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit cmake-multilib
  5. DESCRIPTION="A wrapper to fake privilege separation"
  6. HOMEPAGE="https://cwrap.org/uid_wrapper.html"
  7. SRC_URI="ftp://ftp.samba.org/pub/cwrap/${P}.tar.gz
  8. https://ftp.samba.org/pub/cwrap/${P}.tar.gz"
  9. LICENSE="GPL-3"
  10. SLOT="0"
  11. KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 sparc x86"
  12. IUSE="test"
  13. DEPEND=""
  14. RDEPEND="${DEPEND}"
  15. # https://bugs.gentoo.org/578668
  16. SRC_URI+=" https://git.samba.org/?p=uid_wrapper.git;a=blobdiff_plain;f=src/uid_wrapper.c;h=ded857a1b18f4744bac324b0ccaee3b2d2d146fa;hp=34889e0c3f955ad04bda3859b734a86763dee529;hb=cf2b35344d4de927f158a1e6d5b6bbc1be2ffd96;hpb=a00a6b8b300b7baa867191e2bc016b835cf8d1b3 -> ${PN}-1.2.1-alpha_fix.patch"
  17. PATCHES=(
  18. "${DISTDIR}/${P}-alpha_fix.patch"
  19. )
  20. # Work around a problem with >=dev-util/cmake-3.3.0 (bug #558340)
  21. # Because of this we cannot use cmake-multilib_src_configure() here.
  22. multilib_src_configure() {
  23. local mycmakeargs=( -DCMAKE_LIBRARY_PATH=/usr/$(get_libdir) )
  24. cmake-utils_src_configure
  25. }